Re: FLUGG question

From: <>
Date: Mon, 20 Apr 2009 18:42:53 +0200 (CEST)

  Thank you Paola!
  with your last suggestions FLUGG is working correctly.
  Now I'll try to perform a complete run with Fluka and the FLUGG
  executable. Thank you again.

  Michele Fabi

On Mon, 20 Apr 2009, Paola Sala wrote:

> Dear Michele
> the problem is that the FLUGG and GEANT4 environment variables get mixed
> up. FLUGG uses parts of the GEANT4 scripts in order to build libraries,
> therefore some of the names are the same, and the GEANT4 definitions in
> your bashrc script override the flugg definitions.
> You should take out the GEANT4 definitions from your bashrc when you
> build/run FLUGG.
> Then check that the libraries are produced in $FLUGGINSTALL/lib. The code
> cannot run with the libraries produced in $G4INSTALL/lib, there are a few
> modifications needed that are done when the Install script copies the
> geant4 classes to the flugg directory.
> Hope this helps
> let me know
> Paola
>> Dear Paola,
>> thank you so much for your help. I've re-downloaded the flugg package
>> (and the 32 bit clhep) and recompiled it. Now the executables of the
>> examples in fluggEx are correctly produced, but my example still doesn't
>> work (I'm not a c++ programmer, but I'm working on).
>> At the first try, the gmake command failed because LibG4csg in
>> $G4INSTALL/lib was skipped as incompatible.
>> The command "file" indicated that was 64 bit ELF class.
>> This seemed to me a little strange, because the Install script copy all
>> needed Geant4 parts in FLUGG installation and then the command make in
>> source dir should produce all libs in $FLUGGINSTALL/lib, but I actually
>> don't have any lib directory under FLUGG. Moreover, at every make
>> command
>> in FLUGG/source directory, is overwritten in $G4INSTALL/lib
>> and liblist fail to determine the correct linking list, so geant stop to
>> work.
>> To fix the compilation error, I recompiled geant4 with -m32 flag (I
>> searched in your scripts and added it in the corresponding geant4
>> scripts), and now the executable for each example is produced in
>> $G4WORKDIR/bin/Linux-g++ directory (not in $FLUGGINSTALL/bin/Linux-g++
>> as said in the guide).
>> So FLUGG is working but not as I expected. Am I doing something wrong?
>> Thanks for any suggestion.
>> Michele Fabi.
>> On Thu, 16 Apr 2009, Paola Sala wrote:
>>> Hi
>>> first of all.. re-download the FLUGG tar file, I missed a correction in
>>> the last version, sorry. Now all the relevant scripts have the "-m32"
>>> flag
>>> in. The CLHEP must also be compiled in 32-bit mode, they are available
>>> on
>>> the CLHEp web site. I used clhep- and it
>>> worked.
>>> Please make clean before trying again, and let me know if you have
>>> problems
>>> Paola
>>>> Dear fluka users,
>>>> I'm trying to get confidence with FLUGG, in order to run some Geant4
>>>> geometries on fluka.
>>>> I'm trying to compile FLUGG 2007_3 on scientific linux 5.0 x86_64
>>>> (with
>>>> Geant 4.9.0 p.02, clhep and Fluka 2008). After the Configure
>>>> command I linked the flugg script in my .bashrc
>>>> (a renamed .bashrc and are in attach).
>>>> I ran the Install script (see output file inst). Then in the source
>>>> directory I ran both gmake (output file gmk) and gmake global (output
>>>> file gmkglb) command, but some error occurred.
>>>> If I've correctly understood, all errors are relative to some missing
>>>> files in lib/Linux-g++ in my geant installation, such as
>>>>,,, etc., but
>>>> the
>>>> geant4 building process terminate without errors, so they probably
>>>> are
>>>> not critical. Now, if I try to compile a simple example in emptyEx
>>>> directory a new error comes out. The gmake output (gmkmy in attach)
>>>> say that MyExDetectorConstruction.o is incompatible with my x86_64
>>>> architecture. How can I force the 32 bit compatibility of mainFLUGG?
>>>> Thanks a lot.
>>>> Michele Fabi.
>>> Paola Sala
>>> INFN Milano
>>> tel. Milano +39-0250317374
>>> tel. CERN +41-227679148
> Paola Sala
> INFN Milano
> tel. Milano +39-0250317374
> tel. CERN +41-227679148
Received on Mon Apr 20 2009 - 22:42:58 CEST

This archive was generated by hypermail 2.2.0 : Mon Apr 20 2009 - 22:42:59 CEST