flair on SLC6

From: Moritz Guthoff <Moritz.Guthoff_at_cern.ch>
Date: Thu, 8 Nov 2012 10:09:22 +0100


I am trying to install flair 1.02 and geoviewer on a Scientific Linux 6.

I did install all required packages as described on the homepage. The rpm
installation of flair and geoviewer was successful.
Now I am able to start flair, but the geoviewer is not found. The geoviewer.so
file is present in the flair directory.

In addition there seem to be missing libraries that were not needed with fl=
air 0.98 (the version I used on an other computer before) and on the flair =
homepage these are not given as required. These package versions are not av=
ailable in the Scientific linux package management system:

- python 2.7: Solved by compiling and installing this version by hand
- tcl/tk 8.5: Solved by going from SLC5 to SLC6
- glibc 2.15: SLC6 supports only 2.12 (not solved yet)

These are the ones that I encountered so far. Flair does start up properly,
but gives these errors. Could the reason for the geoviewer not being found
be related to these missing packages? Or what else could I have done wrong
that the geoviewer is not working?
Also: Is it feasible to use SLC5 or SLC6 for a computer dedicated to running
fluka and flair? Since I work at CERN this is the preferred operating sys=
tem. Which OS would you recommend?

Thanks a lot,
Received on Thu Nov 08 2012 - 10:44:58 CET

This archive was generated by hypermail 2.2.0 : Thu Nov 08 2012 - 10:45:29 CET