Re: [fluka-discuss]: Low energy neutrons - Floating point exception

From: Artem Zontikov <>
Date: Fri, 15 Nov 2013 22:10:37 +0300

I could not locate the problem in the source.f subroutine. Here I am
trying to summarize all observed issues.

So, I have a simple geometry which is a cylinder, vacuum and a blackhole
around it.
Source particles are generated via source.f subroutine. Input file and
source subroutine are in the attachment.

The 1st step is running the example with VACUUM attached to the cylinder.
After processing the usrbdx binary we can ensure that "total primaries
run" in the *sum.lis file is equal to the desired one. All calls to the
subroutine were succesfully handled, the subroutine works just as

The 2nd step is running the example with, let's say, OXYGEN attached to
the cylinder. Again all primaries were generated, no warnings in *.out and
*.err files.

The 3rd step is running the example with NITROGEN attached to the
cylinder. An error appears, floating point exception.

And the last step is running the example with NITROGEN attached to the
cylinder and with some other source particle - PHOTON for example. Again
there are no warnings in *.out files.

If the problem has something with subroutine, I think all mentioned cases
would have the same error message.

> Dear Artem
> predefined hydrogen/nitrogen/air/water etc are used routinely with no
> problem in many many problems! There must be something specific in your
> setup (do you use a source routine?) which screws up the neutron
> transport for those materials. From the backtrace you sent, apparently you
> have a neutron at exactly "0" energy....
> Coudl you send the input file and possibly associated user routines?
> +----------------------------------------------------------------------+
> | Alfredo Ferrari || Tel.: + |
> | CERN-EN/STI || Fax.: + |
> | 1211 Geneva 23 || e-mail: |
> | Switzerland || |
> +----------------------------------------------------------------------+
> On Thu, 14 Nov 2013, Artem Zontikov wrote:
>> Hi again,
>> I tried to reproduce this error by attaching different particles to the
>> BEAM card. Other input cards, geometry and SOURCE subroutine were
>> unchanged. It seems it works fine with PHOTON, ELECTRON, POSITRON and
>> PROTON. So, my guess - the error described above (in case of NEUTRON)
>> has
>> something with neutron cross-sections for nitrogen (as I mentioned it is
>> possible to eliminate the problem by attaching other cross-section via
>> LOW-MAT card).
>> I am just wondering if someone tried to run this example? Have you got
>> any
>> warnings in *.out files? Maybe they differ from mine or the problem is
>> with the fortran compiler, operating system, etc...
>>> Dear users and experts,
>>> I've just faced a problem with simulating low-energy neutrons
>>> penetrating
>>> in some pre-defined materials. Fluka 2011.2b-4 crashes with floating
>>> point
>>> exception when pre-defined hydrogen or nitrogen is used (or compounds
>>> with
>>> them - i.e. water or air) as a material. Here is an information from
>>> debug and all other files are in the attachment:
>>> Program terminated with signal 8, Arithmetic exception.
>>> #0 kasneu_ (ekin=0x99487a8, pla=0x9948840, wate=0x9948860,
>>> txx=0x9948848,
>>> tyy=0x9948850, tzz=0x9948858, xx=0x9948740, yy=0x9948748,
>>> zz=0x9948750,
>>> llo=0x9948714, mmreg=0x9948700, ldcynt=0x9943934, ierr=0x9943874)
>>> at kasneu.f:631
>>> #1 0x0811507b in kaskad_ (ierr=0x9943874) at kaskad.f:3844
>>> #2 0x08107841 in feeder_ (kendcn=0x98c9f5c) at feeder.f:257
>>> #3 0x0804e46f in flukam_ (iflgeo=0x8661a98) at flukam.f:3150
>>> #4 0x08049492 in MAIN__ () at fluka.f:289
>>> #5 0x08661989 in main ()
>>> Other pre-defined materials do not reproduce this error. Using LOW-MAT
>>> option with other material's cross-section attached to hydrogen or
>>> nitrogen makes error to disappear as well.
>>> Looking for any help, thanks in advance.

Received on Fri Nov 15 2013 - 21:32:16 CET

This archive was generated by hypermail 2.3.0 : Fri Nov 15 2013 - 21:32:17 CET