[fluka-discuss]: : [fluka-discuss]: installtion of fluka-2011-2c-6 on CentOs 6.6

From: ʢ <yinxiangzi.sheng_at_sphic.org.cn>
Date: Thu, 12 Oct 2017 00:06:36 +0000

Dear all,



Problem is solved by using tar.gz package to install the FLUKA.



Installation of FLUKA using RPM package is very difficult in CetOS 6.6. Even with update of GCC, GFORTRAN, binutils2.26 etc, it will very often fails.



For my experience, very difficult, two days I didn't solve the problem.



However, installation of FLUKA by using tar.gz package is doable, Just need to install an updated GCC>4.6 and Binutils2.26.



Thanks very much for your reply.



Thanks Jixie Zhang, and George!


Joey

________________________________
: zhangjixie_at_gmail.com <zhangjixie_at_gmail.com> Jixie Zhang <jixie_at_jlab.org>
ʱ: 20171011 22:25
ռ: ʢ
: fluka-discuss
: Re: [fluka-discuss]: installtion of fluka-2011-2c-6 on CentOs 6.6

Hi, Joey,

  There are too many dependent libs to install in centos 6.x. Without
root you might not be able to install these dependence.

  The only solution to run fluka in centos6.x is installing 32bit version.
if you want to run 64 bit version, you could use gfortran v5.3 together
with a specific 'gfor5.3' source code.


On Tue, Oct 10, 2017 at 10:43 AM, ʢ <yinxiangzi.sheng_at_sphic.org.cn<mailto:yinxiangzi.sheng_at_sphic.org.cn>> wrote:

Dear experts,


I have successfully instal the fluka-2011-2c-6.x86-64 on fedora 27.

However, when install it on CentOs Version 6.6 errors comes out:


>>rpm -ivh fluka-2011-2c-6.x86-64.rpm

error: Failed dependencies:
        libc.so.6(GLIBC_2.14)(64bit) is needed by fluka-2011.2c-6.x86_64
        libgfortran.so.3(GFORTRAN_1.4)(64bit) is needed by fluka-2011.2c-6.x86_64
        libquadmath.so.0()(64bit) is needed by fluka-2011.2c-6.x86_64

(1) About libc.so.6(GLIBC_2.14)
I know GLIBC version for CentOS 6 is Glibc-2.12, however I didn't successfully install Glibc-2.14 or higher version on this system.
And this server is a cluster, quite difficult to install a new OS such as CentOS 7.
Any other solutions is recommended?

(2)About libgfortran.so.3(GFORTRAN_1.4)(64bit)
This file "libgfortran.so.3" is existed in /usr/lib64/ in my system, And I have put this file path in LD_LIBRARY_PATH, it doesn't work either.

(3)About libquadmath.so.0()
Not sure what it is.

Any suggestions, advises will be really helpfull.

Many thanks.

Joey





--
With Best Regards,
Jixie Zhang
757-269-7735
_______________________________________________

__________________________________________________________________________
You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?id=acc_info
Received on Thu Oct 12 2017 - 03:22:30 CEST

This archive was generated by hypermail 2.3.0 : Thu Oct 12 2017 - 03:22:33 CEST