Re: [fluka-discuss]: Problem compiling fluke 2011.2c-6 on Debian 8

From: Andrea Fontana <andrea.fontana_at_pv.infn.it>
Date: Thu, 9 Nov 2017 19:57:17 +0100

Hi Leon,
   better not to touch a production machine, I agree with you.

Regarding binutils, I have never tried using two different versions
and always used one version: so I have no direct experience.
But binutils is a collection of different tools related to software
development and among these there is the linker "ld": for what concern
your problem, I believe this is the tool that generates the error.

You could try the following: compile binutils in a local directory
from the source (available at: http://ftp.gnu.org/gnu/binutils). Take the
latest version or check the release notes to see what has changed from
version to version  (links at https://www.gnu.org/software/binutils/).
Once this is done, you can try to link the executable with the new
linker (replace the standard ld with the new ld in $FLUPRO/flutil/lfluka)
and see what happens...

One last thing: if you need a standalone machine, you could always
create a virtual machine to do these tests..

Hope this helps.
Kind regards,
Andrea

Il 09/11/2017 18:24, Flaks, Leonid ha scritto:
> Thank you Andrea for you suggestions.
> I saw messages from earlier today and looks like I have identical issue. binutils is at 2.25 for Debian 8. Unfortunately I can’t simply upgrade it. There is no newer version for this distribution - Debian 8 - even on backport channel.
> We run program on a cluster of nodes and I can’t just build different versions of software - it is a production environment and other software could be effected. Debian 9 has a much newer version, but I can’t use it as it is not compatible with our environment.
> I am wondering what was changed in the code from version -5 to -6 that required this binutils upgrade? It seems to break things for Debian 8 as well as RedHat 7 and derivatives (Centos, etc). Those are all officially supported versions.
> The error I got is pointing to some .text file which makes me think that it is just a documentation or similar part of the program.
> My only hope at the moment is to find some stand-alone system with Debian 8, upgrade binutils manually and see if i can exported it into production as a binary file. i am not very excited about this situation.
>
> Is there a way to patch the source so that it would compile on a standard system? Another question - is there a way to install new version of binutils side-by-side with the old one and tell the fluka build process to use the new one?
>
> Thanks,
> Leon
>
>> On Nov 9, 2017, at 11:44 AM, Andrea Fontana <andrea.fontana_at_pv.infn.it> wrote:
>>
>> Hi Leon,
>> just a couple of suggestions, since I have no access to native Debian,
>> but I have succesfully tried the following on Ubuntu:
>>
>> - check the binutils version and updgrade it to a version >= 2.26,
>> as it was suggested to other users today for Fedora and CentOS;
>>
>> - try changing the gfortran version. In Ubuntu (and possibly in Debian,
>> but you have to check) it is possible to easily keep different gfortran
>> versions, since they are named differently (gfortran-6, gfortran-7 ...).
>> While keeping your current version, you can simply make a symbolic link
>> to the version you want to try.
>>
>> For example, you can install gfortran-6 with:
>> apt install gfortran-6
>>
>> then backup your current executable (to be able to revert back):
>> mv /usr/bin/gfortran /usr/bin/gfortran-4
>>
>> and then make a link to the gfortran compiler:
>> ln -s /usr/bin/gfortran-6 /usr/bin/gfortran
>>
>> This requires superuser access, but after this all users can access
>> gfortran-6 by invoking gfortran. It worked on one of our machines...
>>
>> I hope this helps.
>> Best regards,
>> Andrea
>>
>> Il 08/11/2017 22:20, Flaks, Leonid ha scritto:
>>> I am trying to compile the latest version of fluka 20112c-6 on Debian 8.8.
>>> When I run make I got this error:
>>>
>>> COLLECT_GCC_OPTIONS='-msse2' '-mfpmath=sse' '-fPIC' '-O3' '-g' '-mtune=generic' '-fexpensive-optimizations' '-funroll-loops' '-Wall' '-Wuninitialized' '-Wno-tabs' '-Wline-truncation' '-Wno-unused-function' '-Wno-unused-parameter' '-Wno-unused-dummy-argument' '-Wno-unused-variable' '-Wunused-label' '-Waggregate-return' '-Wcast-align' '-Wsystem-headers' '-ftrapping-math' '-frange-check' '-fbackslash' '-fbacktrace' '-ffpe-trap=invalid,zero,overflow' '-finit-local-zero' '-ffixed-form' '-frecord-marker=4' '-funderscoring' '-fno-automatic' '-fd-lines-as-comments' '-fbounds-check' '-I' '/GPFS/APC/fluka-2011.2c-6/flukapro' '-v' '-o' 'gplevbin' '-L/GPFS/APC/fluka-2011.2c-6' '-shared-libgcc' '-march=x86-64'
>>> /usr/lib/gcc/x86_64-linux-gnu/4.9/collect2 -plugin /usr/lib/gcc/x86_64-linux-gnu/4.9/liblto_plugin.so -plugin-opt=/usr/lib/gcc/x86_64-linux-gnu/4.9/lto-wrapper -plugin-opt=-fresolution=/tmp/ccV5VOxP.res -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lgcc -plugin-opt=-pass-through=-lquadmath -plugin-opt=-pass-through=-lm -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lgcc -plugin-opt=-pass-through=-lc -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lgcc --sysroot=/ --build-id --eh-frame-hdr -m elf_x86_64 --hash-style=gnu -dynamic-linker /lib64/ld-linux-x86-64.so.2 -o gplevbin /usr/lib/gcc/x86_64-linux-gnu/4.9/../../../x86_64-linux-gnu/crt1.o /usr/lib/gcc/x86_64-linux-gnu/4.9/../../../x86_64-linux-gnu/crti.o /usr/lib/gcc/x86_64-linux-gnu/4.9/crtbegin.o -L/GPFS/APC/fluka-2011.2c-6 -L/usr/lib/gcc/x86_64-linux-gnu/4.9 -L/usr/lib/gcc/x86_64-linux-gnu/4.9/../../../x86_64-linux-gnu -L/usr/lib/gcc/x86_64-linux-gnu/4.9/../../../../lib -L/lib/x86_64-linux-gnu -L/lib/../lib
 -L/usr/lib/x86_64-linux-gnu -L/usr/lib/../lib -L/usr/lib/gcc/x86_64-linux-gnu/4.9/../../.. gplevbin.o -lflukahp -lgfortran -lm -lgcc_s -lgcc -lquadmath -lm -lgcc_s -lgcc -lc -lgcc_s -lgcc /usr/lib/gcc/x86_64-linux-gnu/4.9/crtend.o /usr/lib/gcc/x86_64-linux-gnu/4.9/../../../x86_64-linux-gnu/crtn.o
>>> /usr/bin/ld: /GPFS/APC/fluka-2011.2c-6/libflukahp.a(dortno.o): unrecognized relocation (0x2a) in section `.text'
>>> /usr/bin/ld: final link failed: Bad value
>>> collect2: error: ld returned 1 exit status
>>>
>>>
>>> There is another screen full of messages, but no other errors. As a result, flukahp has not been made. I have no problem compiling previous version on the same system.
>>> gcc version is 4.9.2
>>> Any suggestions?
>>>
>>> Thanks,
>>> Leon
>>> __________________________________________________________________________
>>> You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?id¬c_info
>>>
>>>
>> --
>> ========================================================================
>> Dr. Andrea Fontana tel: +39 0382 987991
>> Istituto Nazionale fax: +39 0382 423241
>> di Fisica Nucleare
>> Sezione di Pavia e-mail: andrea.fontana_at_pv.infn.it
>> Via Bassi 6 web : www.pv.infn.it/~fontana
>> 27100 PAVIA, Italy
>> ========================================================================
>>
>>
>

-- 
========================================================================
Dr. Andrea Fontana                    tel: +39 0382 987991
Istituto Nazionale                    fax: +39 0382 423241
di Fisica Nucleare
Sezione di Pavia                      e-mail: andrea.fontana_at_pv.infn.it
Via Bassi 6                           web   : www.pv.infn.it/~fontana
27100 PAVIA, Italy
========================================================================
__________________________________________________________________________
You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?idc_info
Received on Thu Nov 09 2017 - 21:18:42 CET

This archive was generated by hypermail 2.3.0 : Thu Nov 09 2017 - 21:18:52 CET