[fluka-discuss]: Re: Fluka Docker - cannot open the file for source.f

From: Horváth Dávid <David.Horvath_at_eli-beams.eu>
Date: Fri, 10 Aug 2018 14:21:26 +0000

Dear Mark,

there is nothing wrong with your setup. The Edit function in flair uses emacs which is not installed in the Docker base image, because it would increase it's size by 40%. The easiest way to edit your input file to use any Windows text editor (Notepad, Atom, etc.), but you can install the "emacs" package, following the instructions in the manual under "Custom package".

You didn't comment the picture you attached, but I assume, it is the overlapping taskbar, you wanted to show us. This is typical Xming behaviour. You can fix the window, by first scaling it down, then maximizing it.

As using file with spaces in their name, I checked how Docker work and it handles these file similarly to my desktop Fedora 28 installation. I have no experience how this was in Fluxpix, but renaming the file would be the easiest and fastest solution.

Kind regards,
Dávid Horváth

Junior Researcher
Radiation Protection
ELI Beamlines

E: david.horvath_at_eli-beams.eu
T: +420 266 051 283
M: Za Radnicí 835, 25241 Dolní Břeľany, Czech Republic

From: mark.ibison_at_cockcroft.ac.uk <mark.ibison_at_cockcroft.ac.uk>
Sent: 10 August 2018 15:27:13
To: Horváth Dávid; fluka-discuss_at_fluka.org; Andrea Fontana
Subject: RE: Fluka Docker - cannot open the file for source.f

Dear FLUKA Discussion,

File Editing in Flair

As a new user of FLUKA for Docker under Windows 7, I have noticed that it does not appear to be possible to use the Edit features of Flair. I find this is necessary when for example amending the Region Volumes directly in the FLUKA *.inp file, as this cannot be done in a simple way in Flair.

I can of course carry out the edits outside Flair, using the Docker shell, but I wondered whether there might be a problem with my set-up which had disabled the Editor? The Viewer does work as normal, however.


File Name Recognition

Another feature which I have noticed and seems to have changed in the latest version is that filenames with spaces in them are no longer recognised. It is not clear whether this arises from Docker or has come from Fluka/Flair. It is a relatively minor issue but has required my older files to be renamed, as most were rather lengthy and had multiple spaces.

Thank you.



-----Original Message-----
From: owner-fluka-discuss_at_mi.infn.it [mailto:owner-fluka-discuss_at_mi.infn.it] On Behalf Of Horváth Dávid
Sent: 06 August 2018 07:42
To: ©evčik Aleksandras <aleksandras.sevcik_at_ktu.edu>; fluka-discuss_at_fluka.org; Andrea Fontana <andrea.fontana_at_pv.infn.it>
Subject: [fluka-discuss]: Re: Fluka Docker - cannot open the file for source.f

Dear Aleksandr,

thank you for reporting the problem!

I assume you are using the same input and source routine you sent to the mailing list a couple day ago. I tried to run your simulation, and I got the same error message.

The reason for the error is, that to make Fluka in Docker work, we had to move the actual location of the Fluka run into another folder. But this doesn't move any other file, like your .dat files.

To make work you need to use absolute path to your .dat file, when you are opening it. For example the OPEN card in your input file should look like this:



Since flair is only capable to add the filename, you will need to use a text editor to modify your input file.

I hope this helps.

Kind regards,



From: owner-fluka-discuss_at_mi.infn.it<mailto:owner-fluka-discuss_at_mi.infn.it> <owner-fluka-discuss_at_mi.infn.it<mailto:owner-fluka-discuss_at_mi.infn.it>> on behalf of ©evčik Aleksandras <aleksandras.sevcik_at_ktu.edu<mailto:aleksandras.sevcik_at_ktu.edu>>

Sent: 06 August 2018 07:18:12

To: fluka-discuss_at_fluka.org<mailto:fluka-discuss_at_fluka.org>

Subject: [fluka-discuss]: Fluka Docker - cannot open the file for source.f


Just for testing purposes I tried Fluka Docker and it compiled ok, the test example and flair works.

I tested my example with custom source that takes the spectrum from *.dat file , which works fine on the linux server.

Here in Docker I get an error:

          File to be opened: linac6000kev.dat

*** Impossible to open file ***


*** on unit 18 ***

**** Error opening unit: 18 file:


**** Run terminated ****




You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?id¬c_info

You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?id¬c_info
Received on Fri Aug 10 2018 - 17:45:31 CEST

This archive was generated by hypermail 2.3.0 : Fri Aug 10 2018 - 17:45:33 CEST