(Fwd) Re: [fluka-discuss]: Error Running Example

From: <luisgona_at_alumni.uv.es>
Date: Tue, 19 Feb 2019 16:06:55 +0100 (CET)

---------- Mensaje reenviado ----------
Para: David.Horvath_at_eli-beams.eu
Asunto: Re: [fluka-discuss]: Error Running Example
Reply-to: luisgona_at_alumni.uv.es
De: <luisgona_at_alumni.uv.es>
Fecha: Tue, 19 Feb 2019 16:05:36 +0100 (CET)

Dear David,

I have done what you advised me. I removed all the FLUKA files and tried to do all the steps again. However when I type "make" now I find this error:

No valid compiler found
make: *** [flukahp] Error 1

With the aim of solving this as soon as possible, I will tell you all the steps I made.
1-I remove all the FLUKA files I had
2-I reinstalled gcc "brew reinstall gcc", so now I have in "/usr/local/bin" two files called "gfortran" and "gfortran-8"
3-I downloaded and moved the "fluka2011.2x-mac-gfor64bit-8.2-AA.tar" package to a folder called FLUKA.
4-I typed the commands "export FLUFOR=gfortran" and
5-cd $FLUPRO and "tar -xvf fluka2011.2x-mac-gfor64bit-8.2-AA.tar"
And then I get this error message

Best regards,
PD:I also tried "export GFORFLU=gfortran" and "export GFORFLU=gfortran-8" with identical result

> Dear Luis,
> the error message suggest a mismatch between the version of gfortran on your system and the one used for compiling the FLUKA package.
> I tested the fluka2011.2x-mac-gfor64bitAA.tar.gz package with a fresh installation of macOS and gcc (homebrew), and it was working.
> You could try to reinstall gcc and redownload/recompile FLUKA again.
> Please check that after download you get the fluka2011.2x-mac-gfor64bit-82-AA.tar in you download folder.
> Kind regards,
> Dávid Horváth
> Junior Researcher
> Radiation Protection
> ELI Beamlines
> E: david.horvath_at_eli-beams.eu
> T: +420 266 051 283
> M: Za Radnicí 835, 25241 Dolní Břežany, Czech Republic
> ________________________________________
> From: owner-fluka-discuss_at_mi.infn.it <owner-fluka-discuss_at_mi.infn.it> on behalf of luisgona_at_alumni.uv.es <luisgona_at_alumni.uv.es>
> Sent: 17 February 2019 20:10:55
> To: fluka-discuss_at_fluka.org
> Subject: [fluka-discuss]: Error Running Example
> Dear fluka experts/users,
> I recently installed fluka for mac and now I am trying unsuccessfully to run an example. However, I keep finding the next error:
> Fortran runtime error: Incorrect extent in VALUE argument to DATE_AND_TIME intrinsic: is 1, should be >=8
> Error termination. Backtrace:
> #0 0x1355f71ac
> #1 0x1355f7e45
> #2 0x1355f811a
> #3 0x1357d9a12
> #4 0x104a6c2d9
> #5 0x10478b475
> #6 0x104a6e5cb
> Regards,
> Luis
> PD: I have read that this is related with the compiler. I have used FLUFOR=gfortran, which is the one I used to install FLUKA. Also when I type "gfortran --version" I get "GNU Fortran (GCC) 8.2.0", so I installed the following pack "fluka2011.2x-mac-gfor64bitAA.tar.gz"(In case this helps)
> Regards,
> Luis
> __________________________________________________________________________
> You can manage unsubscription from this mailing list at https://www.flukaorg/fluka.php?id=acc_info

You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?id=acc_info
Received on Tue Feb 19 2019 - 18:04:10 CET

This archive was generated by hypermail 2.3.0 : Tue Feb 19 2019 - 18:04:42 CET