R: RE: Program received signal SIGFPE: Floating-point exception - erroneous arithmetic operation.

From: <francesca.belloni_at_libero.it>
Date: Sun, 12 May 2013 10:18:19 +0200 (CEST)

Dear Vasilis,
      thank you a lot for your answer.
I added a beam energy in the beam card and shortened the lines with more than
72 characters in the
source.f file, but I still get the same error.
      I cleaned a little the files and they are again in attachment.
The misalignment problems seem to occur when files are being attached, and I
do not know why.
I hope this time files do not result corrupted.
    I have no guess about the problem.
Any suggestion is welcome.

Thank you a lot,
best regards,

>----Messaggio originale----
>Da: Vasilis.Vlachoudis_at_cern.ch
>Data: 10/05/2013 15.48
>A: "francesca.belloni_at_libero.it"<francesca.belloni_at_libero.it>, "fluka-
>Ogg: RE: Program received signal SIGFPE: Floating-point exception -
erroneous arithmetic operation.
>Hi Francesca,
>the files you have send seemed somehow corrupted.
>source.f: all continuation lines are shifted by one space as well some lines
extend over the column 72
>PXGM.inp: the geometry is written in the old COMBINAT format with all
bodies/regions shifted by one space which makes fluka to crash immediately.
>Now the real problem should come from the fact that you didn't specify
anything as beam energy in the BEAM card. Fluka is using this information
(even if you use a custom SOURCE routine) for initializing all cross sections,
dE/dx tabulations etc.
>In your case FLUKA is using 200 GeV/c so it could be that you have a particle
generated from your source routine with higher momentum than 200 GeV/c.
>Best Regards
>From: owner-fluka-discuss_at_mi.infn.it [owner-fluka-discuss_at_mi.infn.it] on
behalf of francesca.belloni_at_libero.it [francesca.belloni_at_libero.it]
>Sent: 08 May 2013 10:38
>To: fluka-discuss_at_fluka.org
>Subject: Program received signal SIGFPE: Floating-point exception -
erroneous arithmetic operation.
>Dear all,
> I had set up a simulation where neutrons pass through
>different media and strike a 10B target, producing
>7LI and 4He. These charged particles enter a gas
>and the energy deposited is scored. I had started with 9E+03 incident
>and evertything seemed to work fine. When I tried to get more statistics, a
>showed up and I do not understand where it comes from.
>The run is aborted more than one hour after it started running (at least on
>the server I am using)
>In the *.err file, here and there, the meassage
> Stepop, Pla < Pthrij!! ij, mmat, ekin, Pla, Pthrij
>appears and in the *.log file the following message is given
>Program received signal SIGFPE: Floating-point exception - erroneous
>arithmetic operation.
>Backtrace for this error:
>#0 0x2BA5DDB6DF37
>#1 0x2BA5DDB6E504
>#2 0x33DD8302CF
>#3 0x33DDC10712
>#4 0x33DDC23A03
>#5 0x4D30AC in zffctv_
>#6 0x4FA780 in kaskad_
>#7 0x4F3C16 in feeder_
>#8 0x40E8FA in flukam_
> I am running the simulation on a server 64 bits
>(uname -a
>Linux dapint 2.6.18-194.11.4.el5 #1 SMP Tue Sep 21 06:46:41 EDT 2010 x86_64
>x86_64 x86_64 GNU/Linux)
>The ROOT version is 5.18/00 and fluka version fluka2011.2-linux-gfor64bit-
>The variables FLUFOR and GFORFLU are set to
>setenv FLUFOR gfortran
>setenv GFORFLU mio-gfortran
>with gfortran -v : gcc version 4.1.2 (GCC)
>and mio-gfortran -v:gcc version 4.5.1 (GCC)
> Could anyone give a look and help me, please?
>Thank you,
>best regards,

Received on Sun May 12 2013 - 11:09:08 CEST

This archive was generated by hypermail 2.3.0 : Sun May 12 2013 - 11:09:09 CEST