RE: [fluka-discuss]: numpy dependence during FLAIR v2.0 installation

From: Vasilis Vlachoudis <>
Date: Tue, 18 Mar 2014 07:44:48 +0000

Hi Angelo, George

the error in both of you comes from the installer.
The numpy is used for the DICOM processing and visualization.

George if flair starts then it means:
either that it finds normally the numpy: so everything functions ok and it is only an installer issue
either you have not installed the pydicom libraries: then the Dicom module is disabled therefore it doesn't require the numpy

Did you install the num using the rpm (george) or the apt-get (angelo)?
If you install it with a different way the rpm or apt-get installer will not be able to find the requirement even if the
library is there and working.


From: Angelo Infantino []
Sent: 18 March 2014 08:35
To: George Kharashvili; Vasilis Vlachoudis
Cc: Fluka discussion
Subject: RE: [fluka-discuss]: numpy dependence during FLAIR v2.0 installation

Dear Vasilis, Dear users,

I have the same problem reported by George with the installation of the .deb files (on Linux Mint).
After the installation of numpy, the dependencies error still appears and not allow the installation of the package.


> Date: Mon, 17 Mar 2014 17:09:57 -0400
> From:
> To:
> CC:
> Subject: [fluka-discuss]: numpy dependence during FLAIR v2.0 installation
> Dear Vasilis,
> FLAIR v2.0 looks great!
> Many compliments to you and everyone involved in development!
> I would like to report about a potential problem:
> When I tried installing flair 2.0 rpm package, I got the following error message:
> error: Failed dependencies:
> numpy is needed by flair-2.0-0.x86_64
> I installed numpy-1.8.0. It seems as it got located in /root/local/lib64/python2.6/site-packages/numpy/ and /usr/lib64/python2.6/site-packages/numpy/
> However, flair rpm would still fail to install due to the same error (numpy needed).
> Then I installed it with --nodeps and everything looks good: input, geometry, run, plot tabs all seem to work just fine.
> Was the "Failed dependencies" message given by mistake, or is there possibly some functionality of flair that may not be working and I just haven't discovered it yet?
> Thank you!
> - George
> ----- Original Message -----
> From: "Vasilis Vlachoudis" <>
> To:,
> Sent: Monday, March 17, 2014 10:50:37 AM
> Subject: [fluka-discuss]: FLAIR v2.0 Announcement
> Dear flair/fluka users
> I am happy to announce to you that "flair V2.0" has just been released on the
> web site
> Its a brand new version featuring a major face lift on its user interface
> focusing on usability. There are plenty of new features in this version,
> which are fully documented in the flair manual.
> I would appreciate if your could test the new version and provide me with
> feedback on problems, comments and suggestions in order to be improved.
> Best Regards
> Vasilis Vlachoudis
> P.S. This message is sent to the fluka-users and fluka-discuss lists as
> well as to some other lists internal to the FLUKA Collaboration. I
> apologize to all those who will get it twice or more
Received on Tue Mar 18 2014 - 09:52:39 CET

This archive was generated by hypermail 2.3.0 : Tue Mar 18 2014 - 09:53:10 CET