[fluka-discuss]: Changes in lfluka?

From: Chris Theis <Christian.Theis_at_cern.ch>
Date: Wed, 20 Aug 2014 17:02:12 +0000

Dear colleagues,

I have been trying to re-use some old code (~2 years old) of mine which partially relied on linking my parser-routines, written in C++, to FLUKA. At that time this worked perfectly fine with a command line like this:

lfluka -m fluka -o myfluka load_particles_src.f parser.o -lstdc++ -L/usr/lib

I now tried to re-use these routines but the linking process failed. Extracting only the relevant lines from the output one can see the following:

ar x fluka.o
ar: fluka.o: No such file or directory

It looks as if specifying the library path via -L on the command line would lead to an empty definition of ${FLU} within lfluka. The help options of lfluka claim that the -L option can be given repeatedly. However, providing "-L $FLUPRO -L/usr/lib" will cause the linker to fail again, this time because libstdc++ cannot be found which is required to resolve the symbols in the object file generated previously by the C/C++ compiler. It seems as if it is actually not possible to give the -L option several times as it would overwrite previous definitions.

As this has been working without a problem before I was wondering if there have been any changes in the lfluka script? I'd also appreciate any hint that could resolve this problem and allow me to stick to using the lfluka script. Otherwise I would have to re-create and adapt the whole compilation chain, which at one point might again lead to discrepancies.

Thanks for your help
Received on Wed Aug 20 2014 - 20:25:30 CEST

This archive was generated by hypermail 2.3.0 : Wed Aug 20 2014 - 20:25:31 CEST