Re: [fluka-discuss]: flair installation problem on UBUNTU 18.04

From: jilberto Zamora Saa <jzamorasaa_at_jinr.ru>
Date: Tue, 22 May 2018 12:13:11 -0400

Dear Andrea:

I could not install python-imaging on ubuntu 18.04, therefore, I back to 16.04 and everything is working fine now.

Thank a lot

Regards Jilberto

> On May 22, 2018, at 1:13 AM, Andrea Fontana <andrea.fontana_at_pv.infn.it> wrote:
>
> Hi Jilberto,
> it seems you miss python-imaging-tk. Please, also make sure you have
> tk-dev and python-dev.
>
> Hope this helps,
> Andrea
>
> Il 21/05/2018 22:55, Jilberto Antonio Zamora Saá ha scritto:
>> Dear Andrea:
>>
>> I have installed:
>>
>> jilberto_at_sirjazs:~$ python
>> python python2 python2.7 python3 python3.6 python3.6m python3m
>>
>> however, the default setted version is:
>>
>> jilberto_at_sirjazs:~$ python --version
>> Python 2.7.15rc1
>>
>> However, when I tried to install python-imaging I got the next message:
>>
>> jilberto_at_sirjazs:~$ sudo apt-get install python-imaging
>> Reading package lists... Done
>> Building dependency tree
>> Reading state information... Done
>> Package python-imaging is not available, but is referred to by another package.
>> This may mean that the package is missing, has been obsoleted, or
>> is only available from another source
>> However the following packages replace it:
>> python-pil:i386 python-pil
>>
>> E: Package 'python-imaging' has no installation candidate
>>
>> I read that python-pil is the equivalen for python-imaging, however, nothing change...
>>
>> regards Jilberto
>>
>>
>> ---
>> *******************************************************************
>> Dr. Jilberto Zamora Saa
>> Dzhelepov Laboratory of Nuclear Problems
>> Joint Institute for Nuclear Research
>> 141980 Dubna, Moscow region, Russia
>> phone: +(496)2162589 (Office)
>> phone: +7(915)4671294 (Mobile)
>> email: jzamorasaa_at_jinr.ru
>>
>> ********************************************************************
>>
>> El 21-05-2018 3:01 pm, Andrea Fontana escribió:
>>> Hi Jilberto,
>>> do you also have python3, alongside with python 2.7?
>>> Perhaps you can check if the environmental variable PATH
>>> is set, as in
>>>
>>> http://www.fluka.org/web_archive/earchive/new-fluka-discuss/11522.html
>>>
>>> Just an idea,
>>> Andrea
>>>
>>> Il 21/05/2018 19:15, Jilberto Antonio Zamora Saá ha scritto:
>>>> Dear Andrea:
>>>>
>>>> I have installed gcc and g++, the following versions:
>>>>
>>>> gcc (Ubuntu 7.3.0-16ubuntu3) 7.3.0
>>>>
>>>> g++ (Ubuntu 7.3.0-16ubuntu3) 7.3.0
>>>>
>>>> I also have installed the other fluka requirements, however, nothing change, I got the same error message.
>>>>
>>>> regards Jilberto
>>>>
>>>> ---
>>>> *******************************************************************
>>>> Dr. Jilberto Zamora Saa
>>>> Dzhelepov Laboratory of Nuclear Problems
>>>> Joint Institute for Nuclear Research
>>>> 141980 Dubna, Moscow region, Russia
>>>> phone: +(496)2162589 (Office)
>>>> phone: +7(915)4671294 (Mobile)
>>>> email: jzamorasaa_at_jinr.ru
>>>>
>>>> ********************************************************************
>>>>
>>>> El 21-05-2018 11:32 am, Andrea Fontana escribió:
>>>>> Hi Jilberto,
>>>>> strange... do you have C and C++ compilers installed on your Ubuntu machine?
>>>>> Which versions? You can verify with the commands:
>>>>>
>>>>> gcc --version
>>>>> g++ --version
>>>>>
>>>>> Also check the other Flair requirements at:
>>>>> http://www.fluka.org/flair/download.html
>>>>>
>>>>> I recommend you install all the indicated packages.
>>>>>
>>>>> Andrea
>>>>>
>>>>>
>>>>> Il 21/05/2018 17:24, Jilberto Antonio Zamora Saá ha scritto:
>>>>>> Dear Andrea:
>>>>>> I already try and got:
>>>>>>
>>>>>> jilberto_at_sirjazs:~/FLAIR/flair-geoviewer-2.3$ make
>>>>>> make -C optimizer
>>>>>> make[1]: Entering directory '/home/jilberto/FLAIR/flair-geoviewer-2.3/optimizer'
>>>>>> c++ -c roi.cc -m64 -DUNIX -O4 -funroll-loops -g -DNDEBUG -D_DEBUG=0 -DTHREAD -Wall -Wcast-align -Wcast-qual -Wextra -Wformat -Wpointer-arith -Wredundant-decls -Wshadow -Wno-write-strings -fwrapv -fstack-protector -fpic -I../utils -I../math -I../graph -I../geometry -I../data -fstrict-aliasing
>>>>>> In file included from ../data/eventbin.h:43:0,
>>>>>> from roi.h:19,
>>>>>> from roi.cc:11:
>>>>>> ../data/usrbin.h: In member function ‘double Usrbin::get(double, double, double, bool*) const’:
>>>>>> ../data/usrbin.h:221:9: error: ‘pow10’ was not declared in this scope
>>>>>> v = pow10(v);
>>>>>> ^~~~~
>>>>>> ../data/usrbin.h:221:9: note: suggested alternative: ‘powl’
>>>>>> v = pow10(v);
>>>>>> ^~~~~
>>>>>> powl
>>>>>> ../data/usrbin.h: In member function ‘double Usrbin::get(int, bool*) const’:
>>>>>> ../data/usrbin.h:228:9: error: ‘pow10’ was not declared in this scope
>>>>>> v = pow10(v);
>>>>>> ^~~~~
>>>>>> ../data/usrbin.h:228:9: note: suggested alternative: ‘powl’
>>>>>> v = pow10(v);
>>>>>> ^~~~~
>>>>>> powl
>>>>>> ../rules.mk:209: recipe for target 'roi.o' failed
>>>>>> make[1]: *** [roi.o] Error 1
>>>>>> make[1]: Leaving directory '/home/jilberto/FLAIR/flair-geoviewer-2.3/optimizer'
>>>>>> makefile:286: recipe for target 'optimizer/liboptimizer.a' failed
>>>>>> make: *** [optimizer/liboptimizer.a] Error 2
>>>>>>
>>>>>>
>>>>>>
>>>>>> regards Jilberto
>>>>>>
>>>>>> ---
>>>>>> *******************************************************************
>>>>>> Dr. Jilberto Zamora Saa
>>>>>> Dzhelepov Laboratory of Nuclear Problems
>>>>>> Joint Institute for Nuclear Research
>>>>>> 141980 Dubna, Moscow region, Russia
>>>>>> phone: +(496)2162589 (Office)
>>>>>> phone: +7(915)4671294 (Mobile)
>>>>>> email: jzamorasaa_at_jinr.ru
>>>>>>
>>>>>> ********************************************************************
>>>>>>
>>>>>> El 21-05-2018 10:34 am, Andrea Fontana escribió:
>>>>>>> Dear Jilberto,
>>>>>>> did you try to install Flair from the tar file
>>>>>>> by running make and make install?
>>>>>>>
>>>>>>> Andrea
>>>>>>>
>>>>>>>
>>>>>>> Il 21/05/2018 15:04, Jilberto Antonio Zamora Saá ha scritto:
>>>>>>>> Dear FLUKA-Experts:
>>>>>>>>
>>>>>>>> I upgraded my OS to UBUNTU 18.04 and I already installed the new FLUKA version (the one which requires gfortran 7.3) which works fine in my system. However, I'm trying to install flair and when I'm going through flair-geoviewer I got the next problem
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> jilberto_at_sirjazs:~/FLUKA$ sudo dpkg -i flair-geoviewer_2.3-0_i386.deb
>>>>>>>> Selecting previously unselected package flair-geoviewer:i386.
>>>>>>>> (Reading database ... 140426 files and directories currently installed.)
>>>>>>>> Preparing to unpack flair-geoviewer_2.3-0_i386.deb ...
>>>>>>>> Unpacking flair-geoviewer:i386 (2.3-0) ...
>>>>>>>> dpkg: dependency problems prevent configuration of flair-geoviewer:i386:
>>>>>>>> flair-geoviewer:i386 depends on flair (= 2.3-0).
>>>>>>>> flair-geoviewer:i386 depends on python-imaging-tk.
>>>>>>>>
>>>>>>>> dpkg: error processing package flair-geoviewer:i386 (--install):
>>>>>>>> dependency problems - leaving unconfigured
>>>>>>>> Errors were encountered while processing:
>>>>>>>> flair-geoviewer:i386
>>>>>>>>
>>>>>>>>
>>>>>>>> I already installed Python 2.7.15rc1 on my system.
>>>>>>>>
>>>>>>>> Any helps will be WELCOME!!
>>>>>>>>
>>>>>>>> regards Jilberto
>>>>>>>>
>>>>>>
>>>>
>>>> __________________________________________________________________________ You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?id=acc_info
>>>>
>>
>
> --
> ========================================================================
> Dr. Andrea Fontana tel: +39 0382 987991
> Istituto Nazionale fax: +39 0382 423241
> di Fisica Nucleare
> Sezione di Pavia e-mail: andrea.fontana_at_pv.infn.it
> Via Bassi 6 web : www.pv.infn.it/~fontana
> 27100 PAVIA, Italy
> ========================================================================
>
> __________________________________________________________________________
> You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?id=acc_info
>

__________________________________________________________________________
You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?idc_info
Received on Tue May 22 2018 - 19:31:45 CEST

This archive was generated by hypermail 2.3.0 : Tue May 22 2018 - 19:31:47 CEST