Re: FLUKA error in Ubuntu

From: Ariel Shnitzer <>
Date: Tue Jul 22 2008 - 20:50:37 CEST

Sorry about the long hiatus, I was working on other issues this past 2
weeks. Thank you all for replying. I have tried all of the solutions
that were emailed to me. I tried:
1. Changing the first line of rfluka, lfluka, and fff to direct to
bash instead of (da)sh
2. Changing the double equal sign in line 308 to a single (= to =)
3. A combination of 1 and 2

Solution 1 made the continual -e go away, although it is moot,
considering that it was only visual, and did not cause any run errors.
  Solution 2 seemed to do nothing, so I undid that change, while
leaving the 3 files in solution 1 to use bash.

I have attached my files in a tar.gz file so that you can see them as
I run them. I also included the outputs generated by FLUKA.

To answer the questions that were asked:
1. I have successfully run FLUKA
2. FLUPRO environmental variable is set to the correct directory
3. One thing I noticed in the output files is a ^M inserted seemingly

One time, when I was trying to debug, I did notice that I accidentally
ran my modified source file with the example input file, and it ran,
although I wasn't sure what to make of the data! Therefore, I agree
with Florian Sommerer that it is the input file that is giving me a
problem somewhere.

      Ariel Shnitzer

Received on Wed Jul 23 10:11:48 2008

This archive was generated by hypermail 2.1.8 : Wed Jul 23 2008 - 10:11:51 CEST