Re: can't using OPEN card

From: Anna Ferrari <>
Date: Mon, 10 Jan 2011 11:57:50 +0100 (CET)

Hallo Hantao,

first of all: you sent all the files of your problem except the one you
want to open... but this is not so important for a first answer.
Also, I have the suspect that the error you report is referring to a first
attempt you did, where you tried to use the OPEN command in the source
routine (I saw the commented lines...).

Let's go by order. I think first that if you want to use the OPEN command
in the file .inp you have to specify as always the complete path of your
file, otherwise FLUKA looks for it in the temporary directory created at
But there is something else: I guess you tried to use the card OPEN in the
input file because you had problems in using the OPEN command in your
SOURCE routine, where you have correctly specified the complete path of
your file. In that case the problem is that you have put the READ command
not in the initialitation block but in the part of the routine that is
read for every new event, so that after the first event the program stops
(because the end of file has been aleady reached). You have just to move
the READ command in the right place.

A last thing. I don't know how is your file with the starting coordinates
of the primaries, I guess you are using a pointlike source and just
rescaling the positions: if this is not the case and you want to use a
spatial distribution you have to sample at each new event from that
distribution, see for example:

Hope it helps,
best regards,


> Dear FLUKA experts,
> When i use a OPEN card to open a file, the following error
> happens in XXX.log file:
> list in: end of file
> apparent state: unit 60 named CS1rev.txt
> last format: list io
> lately reading sequential formatted external IO.
> What is wrong? Thank you in advance!
> Hantao
> 2011.1.10
Received on Mon Jan 10 2011 - 15:05:43 CET

This archive was generated by hypermail 2.2.0 : Mon Jan 10 2011 - 15:05:44 CET