RE: FLUPIX setup - specified directory is not valid

From: <>
Date: Fri, 5 Jul 2013 10:46:44 +0000

Hi Vasilis, All

Many thanks for your reply - I spent another long day trying to get this to work yesterday but I am still having no luck. I must be missing something significant.
All along I have been using the pre-made virtual disks flupix.vdi and swap.vdi, having downloaded these from the FLUKA website.

I have un-installed and re-installed virtual box, and re-downloaded the vdi and iso files many times now to try clean installations.
To start with, here is the summary of the virtual box I created; I believe I have done everything as instructed. At this stage a shared folder is not setup.


When I click "start" to launch this virtual machine I receive a warning about the clipboard manager, and then instantly an error reporting that a specified directory is not valid.


When I explore further it seems that /home/flupix is inaccessible.


And when I try to create a shared folder, as per the instructions, I am still not able as permission is denied.


I didn't really understand your comment in your previous email about what is/isn't possible from windows. Especially now as I specifically didn't setup any shared folders, the error seems to occur even before I attempt to create a shared folder.

>From these screenshots are you able to advise any further as to what the problem here is?

Many thanks again for any help/advice you are able to give


From: Vasilis Vlachoudis []
Sent: 04 July 2013 08:32
To: Smith, Hayley (STFC,RAL,ISIS);
Subject: RE: FLUPIX setup - specified directory is not valid

Hi Hayley,

the two problems are related. In flupix you can only run on the Virtual Disk where you have R/W access. You cannot run on the mounted from the host disks, as windows do not allow to have symbolic links which are required by FLUKA.
To setup the virtual disk either you can use the pre-made one inside, or you can make any virtual disk your self, format it in ext(3/4) format and give it the label "/home"

Best Regards
From:<> [] on behalf of<> []
Sent: 02 July 2013 10:54
Subject: FLUPIX setup - specified directory is not valid
Hello all

I am a new user and have been struggling to successfully run the example in the Flair Quick Start Basic Guide for many weeks now.
I am running Flair through the Virtual Box.

During the geometry debug phase I receive errors:

It appears the FLUKA is trying to run through the /media/sf_vbox directory and I don't think this is correct.
(I have a shared folder setup C:\Documents and Settings\cbn24213\vbox).

I setup Flair according to the instructions and also tried setting up through as they were slightly different.


I have also read various online manuals for configuring virtual hard disks, including as well as searching through archived FLUKA-discuss posts to see if there was anything similar, but there was nothing I could see.

Every time I load the FLUPIX virtual machine I receive an error "The specified directory is not valid", it does not seem possible to access /home/flupix.
Has anyone else experienced the same problem? Or can see a mistake I have made in the setup?

Many thanks for any information/advice you are able to give


Hayley Smith
Accelerator Physicist
ISIS Facility

Rutherford Appleton Laboratory, Didcot, OX11 0QX
01235 445524

-- Scanned by iCritical.

(image/jpeg attachment: image003.jpg)

(image/jpeg attachment: image004.jpg)

(image/jpeg attachment: image005.jpg)

(image/jpeg attachment: image006.jpg)

(image/jpeg attachment: image007.jpg)

(image/jpeg attachment: image008.jpg)

Received on Fri Jul 05 2013 - 14:29:45 CEST

This archive was generated by hypermail 2.3.0 : Fri Jul 05 2013 - 14:29:46 CEST