RE: [fluka-discuss]: Geometry Error

From: <>
Date: Sat, 5 Oct 2013 14:52:35 +0000

Dear Mary

Thank you very much for your reply.

I understand that the way I have this defined is making a lot of expansions and can see this in the output files.
However, I am struggling to see how this can be simplified, as you suggest.

From what I understand, only bodies can be subtracted, rather than regions. So I struggled to simplify in this sense. In the future my geometry will require twenty of these regions defined by planes, so the expansion would be even worse. In your experience what would you suggest as a simplification tactic?

I tried making multiple voids, but this just propagated the expansion problem up to the black body. I think I am still missing some important concepts.

Thanks for any further help you can give,

From: [] on behalf of []
Sent: 04 October 2013 17:00
To: Smith, Hayley (STFC,RAL,ISIS);
Subject: Re: [fluka-discuss]: Geometry Error

Dear Hayley,

The culprit is in the region definition of VOID. Too many expansions; fluka crashes. The debugger works by calling a 'dry' fluka run. So even if you do not use the debugger, fluka still will not run. To solve the problem you can simplify that line of region definition for VOID (which can be easily done using the geometry editor in flair).

:) mary

On 02 October 2013 at 13:49 wrote:
Dear FLUKA users

I am a relatively new user and have been having some difficulties creating the geometry for my current problem.

I have an assembly of twenty graphite blocks, none of which are cubes. Each block has at least one slanted face. I have been trying to create these by using the generic infinite planes and combining these to describe individual blocks as regions. (From what I have read using PLA is the best tool for this?)

I am able to create, debug and plot the geometry for individual blocks.
However, when I wish to debug and plot the geometry of multiple blocks at once the debug routine slows down dramatically, and in the case of wanting to debug more than four of these blocks I receive the error “ERROR RC=34304”.

I have been trying for a number of days to figure out my problem but have now run out of ideas. The geometry does not seem complex to me, so I was surprised that I encountered such an error. Am I asking too much of the memory capabilities? (I am working in Flair on FLUPIX with the standard installation settings as advised on the website).

I have already tried to implement some ideas from the thread however I haven’t had any luck, and can’t really see if my problem is even the same as the problem in that thread.

I attach my input file, showing just a few of these blocks for which the debug crashes, in case it is required for further understanding of my problem.
I am convinced I must be doing something significantly wrong, but am just not able to see it…

Many thanks for any insight you are able to give


Scanned by iCritical.
Scanned by iCritical.
Received on Sat Oct 05 2013 - 16:52:35 CEST

This archive was generated by hypermail 2.3.0 : Sat Oct 05 2013 - 18:09:09 CEST