[fluka-discuss]: 3D Geometry Plotting

From: <hayley.smith_at_stfc.ac.uk>
Date: Fri, 18 Oct 2013 08:53:56 +0000

Dear All

I am puzzled when using the Geometry Editor in Flair.
I have created my geometry (see primaries.inp) and it all looks correct when I inspect the 2D slices (see xz_geometry_y2.png for an example).

However, when I try to create a 3D image of this geometry, suitable for a report, I encounter some behaviour that I have not been able to explain.
In the 3D view the x-axis appears swapped (see 3Dgeoemetry_strange.png)
Also I can pan around, and move the regions without the axes changing. This seems counter-intuitive to me.

I have tried researching various reasons for this, specifically these previous threads:

But I am not sure this is exactly the same problem.

I have tried changing the basis, toggling -u and -v, and setting u to (-1,0,0) amongst many other things, and have read the flair manual for the geometry editor, however none of these have solved the problem of the switch in x axis orientation for the 3D plot.

Especially since everything seemed correct in the 2D slices I was surprised to see the x-axis swap in the 3D plot.

Are you able to offer any further advice as to why this may be the case? Or offer a potential solution?

(For now I have just assumed that the 2D slice geometry to be correct and exported the 3D image to .png and flipped horizontally in another piece of software - but this is not a satisfactory solution for me since the axes then do not display correctly, and I would be concerned about the effect of overlaying USRBIN results etc...)

Many thanks in advance for any assistance you can give


-- Scanned by iCritical.

(image/png attachment: 3Dgeometry_strange.png)

(image/png attachment: xz_geometry_y2.png)

Received on Fri Oct 18 2013 - 11:48:08 CEST

This archive was generated by hypermail 2.3.0 : Fri Oct 18 2013 - 11:48:09 CEST