RE: [fluka-discuss]: 10MeV Electron

From: Stefan Roesler <Stefan.Roesler_at_cern.ch>
Date: Mon, 14 Sep 2015 09:49:20 +0000

Dear Masoomeh

If you are in doubt about results of detectors please convert the data files to ASCII and have a look what you get:

in case of USRBIN you will see

   Region binning n. 1 "D " , generalized particle n. 7
          1 bins corresponding to the region sets:
      from region 29 to region 26 in step of 200 regions, or
      from region 1 to region 1 in step of 200 regions, or
      from region 0 to region 0 in step of 200 regions
      Data follow in an array A(ir), format (1(5x,1p,10(1x,e11.4)))

      accurate deposition along the tracks requested
      this is a track-length binning
       0.0000E+00

      Percentage errors follow in an array A(ir), format (1(5x,1p,10(1x,e11.4)))

       0.0000E+00

Your binning starts with region 29 (D04) and you go in steps of 200 regions, i.e. you will only get results for one region (which apparently shows zero fluence)).

Concerning your USRBDX binning, inspecting the ASCII file it seems that you get zero fluence in all bins (explaining the gnuplot error when plotting).

Regarding the USRTRACK scoring, indeed your number of bins is too large (2000) for the postprocessing tool. If you want to use it I suggest to decrease the number of bins below 1700.

Cheers
Stefan

________________________________________
From: owner-fluka-discuss_at_mi.infn.it [owner-fluka-discuss_at_mi.infn.it] on behalf of Masoomeh Yarmohammadi [myarmohammadi_at_ipm.ir]
Sent: 13 September 2015 15:30
To: fluka-discuss_at_fluka.org
Subject: [fluka-discuss]: 10MeV Electron

Dear Experts,

In the following of the fluka discuss:
 10MeV linac Masoomeh Yarmohammadi (Thu Sep 10 2015 - 15:46:41 CEST)

I have another question. I run the attached inp file, while I set three different scorings: USRBIN, USRTRACK AND USRBDX. I write the related error to each card:

1. The USRBIN scoring, what(1)=12
part:region

The merging the cycles done but the error message is appeared for plotting:


"
set terminal qt 0 enhanced raise title 'Yarmohammadi-phase1-COPPER-V1.flair-0: USRBIN Yarmohammadi-phase1-COPPER-V1 21'

set key default
[Errno 2] No such file or directory: '-Auto-.dat'
"

2. The USRTRACK scoring

error message while merging the cycles with the process bottom is in the following.
"
Processing: Yarmohammadi-phase1-COPPER-V1_25.trk cmd=/usr/local/flukagfor/flutil/ustsuw
>>> Yarmohammadi-phase1-COPPER-V1001_fort.25
>>> Yarmohammadi-phase1-COPPER-V1002_fort.25
>>> Yarmohammadi-phase1-COPPER-V1003_fort.25
>>>
>>> Yarmohammadi-phase1-COPPER-V1_25.trk
 Type the input file: IPM Linac- cylidrical copper target
  DATE: 9/13/15, TIME: 15: 3:44
   20000.0000
       20000
           0
           1
At line 281 of file ustsuw.f
Fortran runtime error: Index '1701' of dimension 1 of array 'accumg' above upper bound of 1700
Processed file is older than some of the dependencies. Maybe the run is still going on?
Error processing: Yarmohammadi-phase1-COPPER-V1_25.trk
Ended: 2015.09.13 15:05:12

Warning
Possible errors: Yarmohammadi-phase1-COPPER-V1_25.trk
Correctly processed:

"

I should mention, I ran the program for USRTRACK while the rest of the scorings are disable, the status changes to "Finished OK". The cycles get fill, green, While the primaries bar are not filled.


3. The USRBDX card:
The cycles get merge But the error appeared in plotting:

"
set terminal qt 0 enhanced raise title 'Yarmohammadi-phase1-COPPER-V1.flair-0: USR-1D Yarmohammadi-phase1-COPPER-V1 23'

set key default
plot 'Yarmohammadi-phase1-COPPER-V1_23_tab.lis' ind 0 us 1:3 w steps lw 2 lc rgb 'red' t 'Detector 1','' ind 0 us (sqrt($1*$2)):3:($3*$4/100.) w errorbars lw 2 lc rgb 'red' pt 0 ps 1 notitle
<e< gnuplot> plot 'Yarmohammadi-phase1-COPPER-V1_23_tab.lis' ind 0 us 1:3 w steps lw 2 lc rgb 'red' t 'Detector 1','' ind 0 us (sqrt($1*$2)):3:($3*$4/100.) w errorbars lw 2 lc rgb 'red' pt 0 ps 1 notitle

<e< ^

<e< line 0: all points y value undefined!

Gnuplot error
"


Looking forward for the solution.

Best regards,

Masoomeh Yarmohammadi Satri
Post-Doctoral Research Fellow, School of Particles and Accelerator, Institute for Research in Fundamental Sciences (IPM)
E-mail : myarmohammadi_at_ipm.ir, myarmoha_at_cern.ch
Best regards

__________________________________________________________________________
You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?idc_info
Received on Mon Sep 14 2015 - 13:26:54 CEST

This archive was generated by hypermail 2.3.0 : Mon Sep 14 2015 - 13:26:55 CEST