Re: [fluka-discuss]: Trouble in implementing a phase space file - iloflk error + Update issue on website ?

From: Jonathan Page <jonathan.page_at_u-bordeaux.fr>
Date: Mon, 10 Jul 2017 17:27:29 +0200 (CEST)

Hi Andrea,

First of all, I am deeply sorry for my late answer, we had some computer issues... Back to normal !
Well, I am using the former version of fluka (2c-5), we tried to update it to the 2c-6 but the link on the fluka website seems to be a link to the 2c-5, strangely ! Can someone double-check this, please?

Indeed, it seems to be a memory related error, but I didn't touch the memory allocation of this particular value since I can't get the hand on the place where this index is attributed...
I am quite lost right now about how to make this work on my computer, however, I am quite glad to see it works on yours. Maybe if I manage to update correctly my code, it would work. If someone could
test with the version 2c-5 (since i'm locked on this one right now), maybe it could help...

In any case, thanks a lot for having a look at my problem.

Jonathan

----- Mail original -----
De: "Andrea Fontana" <andrea.fontana_at_pv.infn.it>
À: "Jonathan Page" <jonathan.page_at_u-bordeaux.fr>
Cc: fluka-discuss_at_fluka.org
Envoyé: Dimanche 2 Juillet 2017 12:08:11
Objet: Re: [fluka-discuss]: Trouble in implementing a phase space file - iloflk error

Hi Jonathan,
  I was able to run succesfully your example with the gfortran version
of the last Fluka release. In any case it seems to be a memory
related error...

Which version of Fluka are you using?

Andrea

> Hello,
>
> I have been trying to implement an external phase space source file into
> FLUKA.
> After having tried to develop it by myself, I used the fortran source file
> present in this thread :
> http://www.fluka.org/web_archive/earchive/new-fluka-discuss/2887.html
> The compilation runs well in both of cases.
>
> However, in both of cases, I have this kind of error after some steps in
> the calculation, around the 150000th simulated particle (the index changes
> for my script, but it is the same matter) :
>
> "At line 250 of file feeder.f
> Fortran runtime error: Index '- 1072324259 ' of dimension 1 of array
> 'iloflk' below lower bound of 0"
>
> So now I don't understand why a negative index is attributed to iloflk,
> and I can't find where feeder.f is located. I found out this subroutine is
> used by the DETECT card... that I do not use.
> When I check the size of iloflk in the fortran file, I can't find anything
> abnormal, as for any information provided by the phase space file who
> seems to be well implemented.
>
> Does anyone have an idea about what's going wrong ? Struggling since some
> days to understand this...
> I join to this email the source file of the previous thread slightly
> modified, my .inp and .flair data, a part of the phase space file.
> N.B : this phase space file is way lighter than the original one (I took
> like 275 particles over more than 1 million...). I tested it with this
> number of particles - and it still gives me this kind of error.
> Don't hesitate to ask me if you need more info/files.
>
> Thanks by advance.
>
> Jonathan Page
>
>


-- 
========================================================================
Dr. Andrea Fontana                    tel: +39 0382 987991
Istituto Nazionale                    fax: +39 0382 423241
di Fisica Nucleare
Sezione di Pavia                      e-mail: andrea.fontana_at_pv.infn.it
Via Bassi 6                           web   : www.pv.infn.it/~fontana
27100 PAVIA, Italy
========================================================================
__________________________________________________________________________
You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?idc_info
Received on Mon Jul 10 2017 - 18:41:40 CEST

This archive was generated by hypermail 2.3.0 : Mon Jul 10 2017 - 18:41:41 CEST