[fluka-discuss]: Problem using last version of FLUKA with Ubuntu 18.04

From: emilio <emilio_at_impcas.ac.cn>
Date: Mon, 28 Sep 2020 17:46:56 +0800 (GMT+08:00)

Dear FLUKA experts,

I have some problems running the latest release of FLUKA in Ubuntu 18.04.

I used FLUKA some years ago (at least until 2017) without any problem; recently I started a new project that requires some simulations, so I installed the last version of FLUKA and Flair, however I had some problems.

First I was getting the error (in the file .log) "Fortran runtime error: Incorrect extent in VALUE argument to DATE_AND_TIME intrinsic: is -2, should be >=8"

Googoling a bit, I found out that the problem was that I had the wrong version of gfortran (7.5). Indeed, even if I had installed both gfortran-7 and gfortran-8, the command "gfortran" was likend by default to version 7. Namely:

emilio_at_Sauron:~/Fluka$ gfortran
gfortran gfortran-7 gfortran-8
emilio_at_Sauron:~/Fluka$ gfortran --version
GNU Fortran (Ubuntu 7.5.0-3ubuntu1~18.04) 7.5.0
Copyright (C) 2017 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO

(there were some problems while running make, I was getting some fatal errors, but I didn't notice at the beginning)

I'm not very familiar with Linux, but I Googled a bit more and I was able to change the version of gfrotran linked to the command using

sudo update-alternatives --install /usr/bin/gfortran gfortran /usr/bin/gfortran-8 60

sudo update-alternatives --install /usr/bin/gfortran gfortran /usr/bin/gfortran-7 40

sudo update-alternatives --config /gfortran

In this way I got

emilio_at_Sauron:~/Fluka$ gfortran --version
GNU Fortran (Ubuntu 8.4.0-1ubuntu1~18.04) 8.4.0

Now I'm able to install FLUKA correctly (I get no more fatal errors), however my code still not cannot run.

Currently, if I try to run a FLUKA code (via Flair), I have an error in the .out file, it will says " Unexpected end of input: START assumed" so many7 times that the .out file will increase very rapidly in size until I kill the process or it fills the entire HD.

I tried to run again some old code, that was working with the previous version of FLUKA, but I got the same results. In the attached files you can find the input card and a "reduced" copy of the output file (I just kept the first error line and cut all the rest, since otherwise it would have been several GB). Please notice also that, in the temporary folder created by Flair, the input card is present but empty, I have no idea whether this is relevant or not.

I should mention that I had some problems during the installation of geoviewer for Flair, I found an answer on this mailing list (http://www.fluka.org/web_archive/earchive/new-fluka-discuss/13766.html) regarding a similar problem and I followed the instructions, changing manually pow10 -> exp10 in some files (of geoviewer, not FLUKA) to fix the problem, however I cannot see how this could create my current problem.

Do you have any suggestions? Does anyone else had a similar problem?

Thank you very much for your help

Best Regards

Emilio Ciuffoli

You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?id=acc_info

Received on Mon Sep 28 2020 - 13:57:40 CEST

This archive was generated by hypermail 2.3.0 : Mon Sep 28 2020 - 13:57:44 CEST