Re: [fluka-discuss]: Possible issue with RESNUCLEI in the last respin?

From: Paola Sala <paola.sala_at_mi.infn.it>
Date: Fri, 16 Apr 2021 17:23:45 +0200

Dear Mauro

I run your input file with your source and the latest fluka respin.

I obtained normal resnuclei outputs and was able to process them

Sorry for the naive questions:

-are you sure that you re-built the executable? You can check in the
output file, after the license and before the echo of input option,
there should be a line with

FLUKA2020 Version 0.10 Apr-21

- are you sure that there isn't an old nuclear.bin or fort.14 in the
directory where you run?

- or in the $FLUPRO directory?

One could also add a RESNUCLEI with output on an ASCII file, to
understand if at least the partial files are produced correctly


..let me know

Paola



On 4/12/21 4:21 PM, Mauro Augelli wrote:
> Dear Paola
>
> sorry to be late in answering.
>
> I am sending attached an example of Input file + related source.f routine for which the RESNUCLEI outputs are not correctly produced/post-processed with the last FLUKA respins.
>
> On the contrary, the input and source routine files were successfully working with the fluka/2020.0.3 version. I checked that the input without associated routine (but with a default source card in the input) works properly also with the new respins.
>
> Just for sake of completeness, the routine has been compiled together with the ldpmqmd executable.
>
> Thanks a lot indeed for your support.
>
> Best regards,
> Mauro
>
>
>
>> On 5 Apr 2021, at 08:26, Paola Sala <paola.sala_at_mi.infn.it> wrote:
>>
>> Dear Mauro,
>> I am sorry but I would need something more to be able to reproduce and understand your problem.
>> Would it be possible for you to send me the input file and source.f?
>> If really not posible, I would need at least one of the fort.xx files containing the RESNUCLEI output before processing, the corresponding RESNUCLEI cards and an idea of projectile/material in your setup.
>> Thanks
>> Paola
>> On 4/1/21 6:34 PM, Mauro Augelli wrote:
>>> Dear Fluka experts
>>>
>>> I have a problem with the RESNUCLEI outputs obtained by running an input file with the last respin of FLUKA (and an associated source.f routine). The same input file and source.f routine worked correctly with the old 2020 FLUKA version.
>>>
>>> The run with the last respin reaches successfully the end but, as a result, all the *.rnc files are empty and the following error is returned when post processing them with usrsuw:
>>>
>>> At line 61 of file evffr/ismrch.f
>>> Fortran runtime error: Index '594' of dimension 1 of array 'izwism' above upper bound of 593
>>>
>>> I have checked that the total expected activity is anyway correctly estimated by the integral value of the USRBIN equivalent output/plot by flair.
>>> So I do not think that the problem is linked to the input file.
>>>
>>> Thanks in advance for your help
>>>
>>> Cheers,
>>> Mauro
>>>
>>> __________________________________________________________________________
>>> You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?id=acc_info
>>>


__________________________________________________________________________
You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?id=acc_info
Received on Fri Apr 16 2021 - 19:41:07 CEST

This archive was generated by hypermail 2.3.0 : Fri Apr 16 2021 - 19:41:09 CEST