Re: Ubuntu 8.10 - missing g77

From: Alfredo Ferrari <>
Date: Sat, 8 Nov 2008 18:18:10 +0100


FLUKA doesn't work with gfortran. First of all it would require
recompiling the whole code (object files produced by g77 and gfortran are
mutually incompatible), and anyway at least until my latest test gfortran
was still miscompiling parts of the code. I didn't have time to pinpoint
which routine(s) and why, also because a previous interaction two years
ago with the gfortran developers was a nightmare to say the least...

So I do not expect FLUKA running on gfortran on a short term
basis (medium term yes), while on a short term there will be
a version running on g95 (look at a fork of gfortran.


  On Sat, 8 Nov 2008, David Horvath wrote:

> Dear Fluka users,
> I upgraded my linux to Ubuntu 8.10 and I tried to complie a Fluka executable,
> but I got the following error: g77 is missing.
> I tried to reinstall it, but it's removed from the package lists.
> I searched the ubuntu forums to find the solution and figured out that now
> ubuntu is supporting the gfortran compiler.
> I set up an alias to use gfortran when I want to use g77, but during the
> comilation doesn't work.
> The old executables are started working after installing the libg2c0 package.
> My question: How can I tell Fluka to use gfortran instead of g77, or somebody
> knows how to install g77 to ubutu 8.10?
> Thank you for your answers.
> Cheers,
> engineering physicist student
> Budapest University of Technology and Economics

|  Alfredo Ferrari                ||  Tel.: +            |
|  CERN-AB                        ||  Fax.: +            |
|  1211 Geneva 23                 ||  e-mail:  |
|  Switzerland                    ||                                   |
Received on Sun Nov 09 2008 - 10:44:25 CET

This archive was generated by hypermail 2.2.0 : Sun Nov 09 2008 - 10:44:25 CET