Re: Ubuntu 8.10 - missing g77

From: Marco Calviani <>
Date: Sat, 08 Nov 2008 18:18:37 +0100

Dear David,

    actually if you install the g77 compiler bundles
with GCC-3.4 using the following command:

$ sudo apt-get install g77

It will automatically pull in the following dependent

gfortran is the new default fortran compiler starting
from GCC-4.0.
However most distributions allow the installation of
older compilers (such as this case) or compatibiliy


David Horvath wrote:
> Dear Fluka users,
> I upgraded my linux to Ubuntu 8.10 and I tried to complie a Fluka
> executable, but I got the following error: g77 is missing.
> I tried to reinstall it, but it's removed from the package lists.
> I searched the ubuntu forums to find the solution and figured out that
> now ubuntu is supporting the gfortran compiler.
> I set up an alias to use gfortran when I want to use g77, but during the
> comilation doesn't work.
> The old executables are started working after installing the libg2c0
> package.
> My question: How can I tell Fluka to use gfortran instead of g77, or
> somebody knows how to install g77 to ubutu 8.10?
> Thank you for your answers.
> Cheers,
> engineering physicist student
> Budapest University of Technology and Economics

   Marco Calviani           tel./fax.: +39 049 8068822
   Universita' di Padova
   INFN - Laboratori Nazionali di Legnaro
   Viale dell'Universita' 2
   35020 Legnaro (Padova)
Received on Sun Nov 09 2008 - 10:44:04 CET

This archive was generated by hypermail 2.2.0 : Sun Nov 09 2008 - 10:44:04 CET