Re: FLUGG question

From: Paola Sala <>
Date: Thu, 16 Apr 2009 11:34:40 +0200 (CEST)

first of all.. re-download the FLUGG tar file, I missed a correction in
the last version, sorry. Now all the relevant scripts have the "-m32" flag
in. The CLHEP must also be compiled in 32-bit mode, they are available on
the CLHEp web site. I used clhep- and it
Please make clean before trying again, and let me know if you have problems

> Dear fluka users,
> I'm trying to get confidence with FLUGG, in order to run some Geant4
> geometries on fluka.
> I'm trying to compile FLUGG 2007_3 on scientific linux 5.0 x86_64 (with
> Geant 4.9.0 p.02, clhep and Fluka 2008). After the Configure
> command I linked the flugg script in my .bashrc
> (a renamed .bashrc and are in attach).
> I ran the Install script (see output file inst). Then in the source
> directory I ran both gmake (output file gmk) and gmake global (output
> file gmkglb) command, but some error occurred.
> If I've correctly understood, all errors are relative to some missing
> files in lib/Linux-g++ in my geant installation, such as
>,,, etc., but the
> geant4 building process terminate without errors, so they probably are
> not critical. Now, if I try to compile a simple example in emptyEx
> directory a new error comes out. The gmake output (gmkmy in attach)
> say that MyExDetectorConstruction.o is incompatible with my x86_64
> architecture. How can I force the 32 bit compatibility of mainFLUGG?
> Thanks a lot.
> Michele Fabi.

Paola Sala
INFN Milano
tel. Milano +39-0250317374
tel. CERN +41-227679148
Received on Thu Apr 16 2009 - 14:37:42 CEST

This archive was generated by hypermail 2.2.0 : Thu Apr 16 2009 - 14:37:42 CEST