RE: Fluka 2011.2b.3 problem? [NP]

From: Sebastian Galer <>
Date: Thu, 11 Jul 2013 15:09:08 +0100

Dear Alberto,

Thanks for your prompt reply. I have tried 'ls flukahp' (as well as ls
and looking in the file explorer) and the file isn't there despite the
successful make.

I also tried to make flukahp directly from 'make flukahp' and get the

[root_at_localhost fluka]# make flukahp
FLUPRO=/usr/local/fluka flutil/lfluka -o flukahp -m fluka $FLUPRO =
/usr/local/fluka now linking /usr/local/fluka
ar x /usr/local/fluka/libflukahp.a fluka.o
g77 -m32 -O3 -g -fexpensive-optimizations -funroll-loops
-fstrength-reduce -Wall -fno-automatic -fno-silent
-ffortran-bounds-check -I/usr/local/fluka/flukapro -v -o flukahp
-Xlinker -Map -Xlinker fluka.o -L/usr/local/fluka -lflukahp
Driving: g77 -m32 -O3 -g -fexpensive-optimizations -funroll-loops
-fstrength-reduce -Wall -fno-automatic -fno-silent
-ffortran-bounds-check -I/usr/local/fluka/flukapro -v -o flukahp
-Xlinker -Map -Xlinker fluka.o -L/usr/local/fluka -lflukahp
-lfrtbegin -lg2c -lm -shared-libgcc Reading specs from
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --with-system-zlib --enable-__cxa_atexit
--disable-libunwind-exceptions --enable-languages=c,c++,f77
--disable-libgcj --host=i686-redhat-linux Thread model: posix gcc
version 3.4.6 20060404 (Red Hat 3.4.6-24.fc17)
  /usr/libexec/gcc/i686-redhat-linux/3.4.6/collect2 --eh-frame-hdr -m
elf_i386 -dynamic-linker /lib/ -o flukahp
/usr/lib/gcc/i686-redhat-linux/3.4.6/crtbegin.o -L/usr/local/fluka
-L/usr/lib/gcc/i686-redhat-linux/3.4.6/../../.. -Map fluka.o
-lflukahp -lfrtbegin -lg2c -lm -lgcc_s -lgcc -lc -lgcc_s -lgcc
/usr/local/fluka/libflukahp.a(flkcgi.o): In function `flkcgi_':
(.text+0x1749): undefined reference to `ckdfvl_'
collect2: ld returned 1 exit status

If I do an ls now I get:

[root_at_localhost fluka]# ls
12cqmd.inp LICENSE.fluka2011.2b dpmjet
fluka2011.manual grv98lo.grid interface librqmdmvax.a
random.dat usermvax
12ctst.inp README
grv98lof.grid makefile sidae.dat xnloan.dat
CERN-2005-10.pdf RELEASE-NOTES.fluka2011.2b elasct.bin flukapro
grv98nld.grid makeflags sidan.dat
DDS Version.tag example.inp fluodt.dat
grv98nlf.grid latestRQMD neuxsc-ind_260.bin sidap.dat
FM.pdf brems_fin.bin exfixed.inp flutil
grv98nlm.grid libdpmmvax.a nuclear.bin sidapi.dat
Fad cohff.bin exmixed.inp gcrtools
gxsect.bin libflukahp.a sigmapi.bin

Any other thoughts you have on what I have done wrong would be


The output you got is the usual one from a successful make.
The files not found are all "map" files, which are not essential.
If you type
ls flukahp
you will see that it has been created.

If you have further enquiries, please keep them on the discussion list:
I am not the only one who can answer you.


On Thu, 11 Jul 2013, Sebastian Galer wrote:

-----Original Message-----
[] On Behalf Of Alberto Fasso'
Sent: 11 July 2013 12:36
Cc: Sebastian Galer
Subject: Re: Fluka 2011.2b.3 problem?

In the $FLUPRO directory, type
and flukahp will be created.

It has been like this since a long time. You must have forgotten


On Thu, 11 Jul 2013, Sebastian Galer wrote:

> Hi,
> I downloaded the 2011.2b.3 version yesterday and tried to run it but
> it can't find the flukahp file (normally in usr/local/fluka). I have
> tried to re-download it today and still have the same problem.
> I am running it from the iso under virtualbox as I have with previous
> version in the past (without any problems).
> Any thoughts would be appreciated.
> Thanks,
> Seb

If you have received this message in error, please notify us and remove it from your system.
NPL Management Ltd cannot guarantee that the e-mail or any attachments are free from viruses.
NPL Management Ltd is a company registered in England and Wales, number: 2937881
Registered office: Serco House | 16 Bartley Wood Business Park | Hook, Hampshire | UK | RG27 9UY
Received on Thu Jul 11 2013 - 18:34:16 CEST

This archive was generated by hypermail 2.3.0 : Thu Jul 11 2013 - 18:34:16 CEST