[fluka-discuss]: RE: FLUGG Installation

From: James Ryan <james.ryan-4_at_postgrad.manchester.ac.uk>
Date: Fri, 25 Oct 2013 10:52:07 +0000

Hi Vasilis,

Thanks for getting back to me.

Do you mean when building FLUGG enter "gmake -m32"? Because that doesn't work unfortunately, it says:

gmake -m32
gmake: invalid option -- '3'
gmake: invalid option -- '2'

I tried with just "gmake -m" and it still encountered the same error in WrapSavHist.cc. I've also tried "make" instead of "gmake" but with no luck. Any ideas what's going on?

Many thanks,
James Ryan
Nuclear FiRST DTC
University of Manchester

From: Vasilis Vlachoudis [Vasilis.Vlachoudis_at_cern.ch]
Sent: 25 October 2013 9:11 AM
To: James Ryan; fluka-discuss_at_fluka.org
Subject: RE: FLUGG Installation

Hi James,

It seems a problem with CLHEP at 64bit, since it tries to cast a pointer 64bit to int 32bit. Could you try compile it for 32bit
with the -m32 option


From: owner-fluka-discuss_at_mi.infn.it [owner-fluka-discuss_at_mi.infn.it] on behalf of James Ryan [james.ryan-4_at_postgrad.manchester.ac.uk]
Sent: 24 October 2013 18:49
To: fluka-discuss_at_fluka.org
Subject: [fluka-discuss]: FLUGG Installation

Hi everyone,

Having a few problems with the installation of FLUGG. I've got GEANT4/FLUKA/CLHEP installed fine and then moved onto trying to get FLUGG up and running.

Following the instructions from http://www.fluka.org/content/tools/flugg/node5.html I've unpacked the tar file and set all my environmental variables appropriately. I carry out the "./Install" command without issue, then cd to the source directory. The problem then occurs when using the "make" command.

It runs through for a few minutes and compiles most things just fine but it gives an error when trying to compile WrapSavHist.cc, the error is:

Compiling WrapSavHist.cc ...
src/WrapSavHist.cc: In function ‘G4int isvhwr_(const G4int&, const G4int&)’:
src/WrapSavHist.cc:98:48: error: cast from ‘NavHistWithCount*’ to ‘G4int {aka int}’ loses precision [-fpermissive]
src/WrapSavHist.cc:122:42: error: cast from ‘NavHistWithCount*’ to ‘G4int {aka int}’ loses precision [-fpermissive]
In file included from /samdata1/jryan/FLUGG/source/global/management/include/G4PhysicalConstants.hh:27:0,
                 from /samdata1/jryan/FLUGG/source/global/management/include/globals.hh:70,
                 from include/Wrappers.hh:13,
                 from src/WrapSavHist.cc:27:
/samdata1/jryan/CLHEP/x86_64-slc6-gcc47-opt/include/CLHEP/Units/PhysicalConstants.h: At global scope:
/samdata1/jryan/CLHEP/x86_64-slc6-gcc47-opt/include/CLHEP/Units/PhysicalConstants.h:80:21: warning: ‘CLHEP::electron_charge’ defined but not used [-Wunused-variable]
gmake[1]: *** [/samdata1/jryan/FLUGG/tmp/Linux-g++/FggWrappers/WrapSavHist.o] Error 1

There's more text below but it didn't look relevant (if it actually is I can add that also).

Any advice would be greatly appreciated.

James Ryan
Nuclear FiRST DTC
University of Manchester
Received on Fri Oct 25 2013 - 13:35:01 CEST

This archive was generated by hypermail 2.3.0 : Fri Oct 25 2013 - 13:35:02 CEST