RE: [fluka-discuss]: Flair's problem with the new version of Ubuntu

From: Ferreira De Almeida Lourenco, Ana <>
Date: Wed, 23 Apr 2014 12:14:47 +0000

Dear Duy and all

Many thanks for your e-mail, it worked for me as well.

For those who can't find the files on that specific directories (usr/lib or /usr/lib/i386-linux-gnu) I recommend to run the following commands first. For example, in my case they were on /usr/lib/x86_64-linux-gnu

sudo find / -name ''
sudo find / -name ''

Best wishes,


De: <> em nome de Duy Trinh Ngoc <>
Enviado: domingo, 20 de Abril de 2014 13:48
Assunto: Re: [fluka-discuss]: Flair's problem with the new version of Ubuntu

Hi everyone,

Now I finally fixed this problem. There are this error because in the newest version of Ubuntu (Ubuntu 14.04) the libraries libtk and libtcl has been updated to the version 8.6 , but Flair still works with the older version 8.5 . So all i have to do is make two symbolic links like this:

ln -s<> and ln -s<>

And now it works ok . I hope Flair developer will fix soon this error by updating Flair.

Thank everyone.

My last emails:

Dear everyone,
Today i have just upgraded Ubuntu to the newest version Ubuntu 14.04. Everything is ok but when i use Flair there are this error:
Warning: Geometry Viewer not found

Error:<>: cannot open shared object file: No such file or directory

I tried to follow the instruction of the website of Flair:

Please make a symbolic link as super user:

  1. Locate the tk/tcl libraries either one of the following directories
     * /usr/lib
     * /usr/lib/i386-linux-gnu
  2. change to that directory e.g.

$ cd /usr/lib

  3. make the symbolic links:

$ ln -s<>

$ ln -s<> "

But it doesn't work, i don't know how to do to fix it. So do you have any idea to help me?

Thanks in advance."
Received on Wed Apr 23 2014 - 15:18:05 CEST

This archive was generated by hypermail 2.3.0 : Wed Apr 23 2014 - 15:18:07 CEST