RE: Re: [fluka-discuss]: Problems when I tried to merge the USRBIN datasin flair

From: <>
Date: Tue, 6 May 2014 11:00:15 +0000

Thank you Vittorio.
I was running the virtual machine with a base memory of 768 MB. Increasing this, as you suggested, to 1024 MB appears to have fixed the problem.

Thank you very much for all of your help, it is much appreciated.

From: Vittorio Boccone []
Sent: 01 May 2014 21:23
To: Smith, Hayley (STFC,RAL,ISIS)
Subject: Re: Re: [fluka-discuss]: Problems when I tried to merge the USRBIN datasin flair

Hi Hayley,

I should also add, that when I tried the suggestion to do cd/usr/local/fluka/flutil and $FLUPRO/flutil/lfluka -o usbsuw usbsuw.f
you can't do this directly, you should do it through sudo (being superuser).

>sudo $FLUPRO/flutil/lfluka -o usbsuw usbsuw.f
At first look ignored the message of the terminal in your first email. It doesn't seems a problem with FLUKA or FLUPIX distribution. Looks there's something with your virtual machine configuration.
The "Killed" signal is generally the result of a hungry program that tries to allocate too much memory (can also be the "wanted" byproduct of the kill command)

I would guess your virtual machine is still configured for the old flupix (256MB or 512 MB of RAM). I would bet a beer is that.
Beef up the RAM on your virtual machine (at least 1 GB if you can...)

In case it's not that:
1) I lost a beer
2) Could you post the full configuration you are using? Host computer, total RAM and architecture VBox version, and the configuration you are using for flupix (RAM, cores assigned to the machine etc...)

On Thu, May 1, 2014 at 2:01 PM, <<>> wrote:
Thanks Ana – yes I saw the new version on FLUPIX was available this morning, I downloaded this and re-ran my simulations, but unfortunately I encountered exactly the same problem when attempting to merge the USRBIN files… (see screenshot below)

So I’m still not sure if there is a different problem?
Or am I doing something wrong?



From: Ferreira De Almeida Lourenco, Ana [<>]
Sent: 01 May 2014 11:57
To: Smith, Hayley (STFC,RAL,ISIS);<>
Subject: RE: Re: [fluka-discuss]: Problems when I tried to merge the USRBIN datasin flair

Dear Hayley and everyone

I used to get the same error - I think it was due to a last version of FLUKA on FLUPIX. I think FLUPIX was updated yesterday, so if you install it you should be able to run it without problems.

Hope that helps!

Best wishes,


De:<> <<>> em nome de<> <<>>
Enviado: quarta-feira, 30 de Abril de 2014 15:05
Assunto: FW: Re: [fluka-discuss]: Problems when I tried to merge the USRBIN datasin flair

Dear All

I have also encountered the problem regarding merging USRBIN data sets (mentioned in the thread below), see screenshot.
I have tried the solution suggested, but I am still unable to successfully merge USRBIN data.

Is anyone able to offer any other suggestions, or possible reasons for the problems?
I am using the current version of FLUPIX flupix-2011:2b-5_flair-1.2-5.iso and didn’t used to have any problems in the previous version.

My input file is attached, in case that is also relevant. I have also tried testing with a the tutorial files and have re-read my course notes, but I am now at a loss as to what is wrong…

Many thanks for any further suggestions you are able to give,

Hayley Smith

Accelerator Physicist
ISIS Facility
Rutherford Appleton Laboratory
Harwell Oxford
OX11 0QX

01235 445524<>


From: nikhil shetty []
Sent: 29 March 2014 14:18
To: 徐妙华
Cc: fluka-discuss
Subject: Re: Re: [fluka-discuss]: Problems when I tried to merge the USRBIN datasin flair

I refer you to this thread, where a similar problem was treated:
It seems for some reason the executable required to postprocess USRBIN files is missing. I suggest you to try the following steps:
1) cd /usr/local/fluka/flutil
2) $FLUPRO/flutil/lfluka -o usbsuw usbsuw.f
3) $FLUPRO/flutil/lfluka -o usbrea usbrea.f
Now try merging the USRBIN files again. Hope it works.

On Sat, Mar 29, 2014 at 2:01 AM, 徐妙华 <<>> wrote:
When I merged the USRBIN data in "tutorial.flair", the output window said "Error processing: tutorial_usrbin_50".

As in the case of "example.inp", it said almost the same: "Error procssing: example_50.bnn".



发件人:nikhil shetty <<>>
抄 送: fluka-discuss <<>>
发送时间:2014-03-29 01:46:03
主题:Re: [fluka-discuss]: Problems when I tried to merge the USRBIN datasin flair


Did you actually check for the error message in the output? What does it say?


On Friday, March 28, 2014, 徐妙华 <<>> wrote:
Dear FLAIR experts,

 I ran the "tutorial.flair" with the lastest flair version in the virtual box. There were no problems in the run simulation.And also when I merged the data of "tutorial_usrcoll_51" and the "tutorial_resnuclei",everything was good. I can get the merged data file and succeed in plotting. However, when I tried to merge the data of "USRBIN", I got the message "Please check output for possible errors on file: tutorial_usrbin_50", and then "No files were created". I tried the other input files, such as the "example.inp". The merging of "USRBDX" and the "USRTRACK" data is just fine, while there is always problems when I merged the "USRBIN" data.

This error seemed quite strange for me. Can anyone tell me the reason and how to solve this problem?
Thank you very much!



Scanned by iCritical.

(image/jpeg attachment: image001.jpg)

(image/jpeg attachment: image002.jpg)

(image/png attachment: image003.png)

(image/png attachment: beer.png)

Received on Tue May 06 2014 - 14:42:12 CEST

This archive was generated by hypermail 2.3.0 : Tue May 06 2014 - 14:42:13 CEST