Re: [fluka-discuss]: Switching from FLUKA g77 to FLUKA gfortran

From: Alessandro Calamida <alex.calamida2_at_tiscalinet.it>
Date: Mon, 12 Apr 2021 16:21:01 +0200

Dear Paola,

The problem happens with neutron beam energy below 100 meV. The neutrons
have to cross a layer of cadmium to eliminate the epithermal neutrons
and then one of polythylene as a moderator. Then it found a LiF
conversion layer, a silicon detector and the water body. I run the
simulations also with a simpler geometry with only the detector alone
that I will attach on this email. The problem happens in this case too
when the starting energy of the neutron beam is below 100 meV. FLUKA
gives me segmantation fault and this happens only on the server and not
on my PC. The only difference in the two FLUKA is that on the server I
use the g77 version, on the PC the gfortran9 one.

For the installation on the server of the gfortran version is that on it
there is gfortran4 or at maximum gfortran7. I tried to ask for a newer
version to their assistance and they answered saying that I have to
think on my own. The problem is that installing gcc9 without the sudo
privilege is a very difficoult task. The FLUKA version for gfortran9
could also work with gfortran7. Because with gfortran4 I remember that
it did not work.

Best regards and thank you for your time, Alessandro Calamida.

Il 12/04/2021 08:43, Paola Sala ha scritto:
> Dera Alessandro
>
> sorry for the huge delay -)
>
> First of all, it is very strange that you get a segfault in g77 and
> not in gfortran. Maybe it's a real problem! If you cannot send the
> input file, could you
>
> describe the problem:
>
> -beam particle and energy
>
> -target material
>
> -defaults used
>
> For gfortran7, you can try with the gfortran8 fluka tar file
>
> Paola
>
> On 3/16/21 11:29 AM, Alessandro Calamida wrote:
>> Dear FLUKA experts,
>>
>> I have installed the g77 version of FLUKA on a server. However, when
>> I run simulations with very low energy particles, the simulations
>> goes in segmentation fault. I think that this is caused by the fact
>> that the variable become to long when it went to small. The g77
>> compiler is still based on the punchtrhough cards and when the
>> variable stored become too long it goes out of boundaries and this
>> maybe causes the error. I tried to run the same simulations on my
>> computer that uses the gfortran version and this error did not happen
>> even for very low energies (below 100 ueV).
>>
>> So, I want to install the gfortran version on this sever. However, on
>> it there is only gfortran4 or gfortran7. To run FLUKA I need
>> gfortran9 but I have no root permission and I cannot use sudo. Do you
>> know a way to install gfortran9 without it? Beacause on the web I did
>> not find any clue about it.
>>
>> Best regards and thank you for your time, Alessandro Calamida.
>>
>>


-- 
Questa e-mail  stata controllata per individuare virus con Avast antivirus.
https://www.avast.com/antivirus



__________________________________________________________________________
You can manage unsubscription from this mailing list at https://www.fluka.org/fluka.php?id=acc_info

Received on Mon Apr 12 2021 - 18:09:22 CEST

This archive was generated by hypermail 2.3.0 : Mon Apr 12 2021 - 18:09:25 CEST